Manage Software Downloads

Mac OS X 10.10 Yosemite

UIT encourages all users to work with their IT managers before upgrading to ensure 3rd party software compatibility. Please work with your IT manager to ensure that any pertinent software is compatible before updating your device.

Requirements

To install Yosemite, you need one of the following:

iMac (Mid 2007 or newer)

MacBook (Late 2008 Aluminum, or Early 2009 or newer)

MacBook Pro (Mid/Late 2007 or newer)

MacBook Air (Late 2008 or newer)

Mac mini (Early 2009 or newer)

Mac Pro (Early 2008 or newer)

Xserve (Early 2009)

Your machine also needs:

OS X v10.6.8 or later

2GB of memory

8GB of available storage

Some features require an Apple ID; terms apply.

page last updated: August 12, 2016
For questions or problems, email software@uh.edu or call 713-743-1411.